Errors with Grasp Object Demo


It seems like I have problems running the grasp_object.launch file in the demo, I’m using Stretch RE2 (2020) with the default gripper, running on Ubuntu 20.04 and ROS Noetic, as per image attached below, it keeps displaying a warning about unable to get base to fixed frame after I launched the demo with roslaunch stretch_demos grasp_object.launch

After the keyboard instructions showed up in the terminal, I pressed the key with ’ and " as mentioned in the instructions, what the robot did is turning the head around more than 100 degree to the right and the gripper also pointed out, but after that the robot always comes to a halt.

I believe this screenshot might be helpful, I think it’s indicating that the robot can’t detect the floor?

I have recalibrated the URDF but the robot doesn’t seems to have any improvement.

Thank you for your assistance in advanced!

Hello @thieulong, welcome to the Stretch community forum! There’s a lot of warnings in the screenshot you’ve shared, each reporting a TF2 failure to lookup a transform. Those warnings are actually unnecessary, and result from a bug inside the laser scan matching node. We fixed the issue in this commit. Would you refresh your ROS software (instructions on how to do this available here if you need it)? This should eliminate those warnings.

Those warnings are unrelated to the issue you’re having with getting the Grasp Object demo working, but they are hiding the important logs. Try running the demo again after you’ve updated your software, so we can see the relevant errors when the demo fails.

Hello @bshah

Thank you very much for your reply,

I’ve refreshed my ROS environment as per the instructions, and I tried to run the demo again, it still doesn’t work but I think I can provide you a better output this time.

The first one is there is a problem with RVIZ that the robot is unable to open RVIZ when running this grasp_object demo. When I run roslaunch stretch_demos grasp_pbject.launch, this error shows up:

RLException: roslaunch file contains multiple nodes named [/rviz].
Please check all ‘name’ attributes to make sure they are unique.
Also check that $(anon id) use different ids.
The traceback for the exception was written to the log file

And this is the output when I disabled RVIZ to run the demo, when I pressed they key with ’ and ", the robot only turns it head over the right side (with an angle of more than 100 degree), the arm doesn’t extract as well as no signal from the gripper, this is the screenshot of the output.

Perhaps I’ve done something wrong? Can you give me some insights please?

Thank you!

Hi @thieulong, when you roslaunch stretch_demos grasp_object.launch, the log will print out a list of nodes and parameters being launched. This will be at the top of the log. This should help us identify why ROS thinks multiple nodes named /rviz are being launched. Would you post this log here?

Regarding the second issue, I’d ask that you confirm that your set-up closely matches the nominal set-up shown in the grasping video: a small flat table set adjacent to the robot with only 1 object on it, with clear lighting and no wall behind the table. Second, when the grasp object demo runs, debug images are logged to the ~/stretch_user/debug directory on your robot. The images logged there can help us understand what the node is seeing. For example, in the image below:

The three debug images show what the robot sees, the 2 in ~/stretch_user/debug/grasp_object/ show a overhead RGB and depth image of the table with the water bottle on it. The image in ~/stretch_user/debug/get_grasp_target/ shows what the grasp_object node thinks. Green is what FUNMAP thinks the surface is, red is the points above the surface (i.e. the object to grasp), and the white lines w/black outline is the major and minor axis of an ellipse estimated to represent the object to grasp (grasp_object attempts to grasp the object around the minor axis).