Camera and Lidar not working

I am using Stretch RE1. I have recently started using it following the tutorials. I have been trying to use Camera and Lidar, but it is not working.


My Stretch RE1 has Linux version 18 and ROS Melodic. I also updated the stretch body and stretch body tool. I cannot run the roslaunch stretch_core stretch_driver.launch command.

Thank you

Hi @Rupesh, welcome to the forum! That error means ROS can’t find Stretch’s ROS packages. There’s a few reasons why this might be happening. Start by opening a file explorer and confirming you have a ROS workspace called “catkin_ws”.

Additionally, I’d recommend upgrading to Ubuntu 20.04 and ROS Noetic since that’s where the most up to date software lives.

Thanks, I upgraded the ubuntu as you suggested, the camera and lidar are working smoothly.

But, Dex Wrist (Gripper) has stopped working after installation.
When I ran “”, I got
Screenshot 2023-03-20 181906

Also, after running
“cd ~/stretch_install
./” , I did not get any error. But the terminal gets stucked in following. Although I wait for a very long time, it won’t proceed.

Can you please help me with this?

Great! Regarding the stuck terminal, if you’ve still got it open, can you try Ctrl C-ing in the terminal? Regarding the dex wrist issue, can you run and send me the output?

To clarify, that’s /dev/hello-dynamixel-wrist .

1 Like

Hi, thank you for your support. After running that, I got this.

Great, thanks! The Dex Wrist communicates on a serial bus at 115200 baud (i.e the speed of communication). Notice how servo 14 is detected with baud rate 57600. Changing servo 14’s baud rate to 115200 should make one of the unpingable servos come back online. Use the following command to change the baud rate: /dev/hello-dynamixel-wrist 14 115200

2 of the 4 total servos did not show up in the ID scan you did. Usually this happens because there’s a loose or damaged cable. Would you investigate the cables in gripper’s wrist and confirm they’re all undamaged and plugged in. Here’s a picture of what the cable looks like:

Thanks, One of them started working. Do you mean this cable? It looks good. Also, it was working smoothly before upgrade.

Also, I haven’t seen any pitch and roll movement in that gripper before. I have only seen yaw and grip movement. I also don’t see any joints to achieve that.
Screenshot 2023-03-21 121152
I cannot even home because of that.

Hey @Rupesh, looks like your robot’s software is configured mistakenly for the DexWrist end-of-arm tool instead of the Standard Wrist end-of-arm tool. You can use the Dex to Standard Wrist - Software Instructions to configure your robot to support the Standard Wrist. Also, make sure the robot’s Runstop is not activated before homing.
Let us know if this fixes the homing issue.

Thank you so much for your help. Its solved.