Realsense failure issues

The RealSense D435i on one of our Stretch RE1s has been failing consistently for over a month now. There are days where the camera will not work at all for the entire day.
We have done a firmware update on the camera.
This is Ubuntu 20.04 and ROS Noetic
System check passes on realsense

If we run realsense-viewer We get the following errors in the terminal

The viewer also outputs the following error:
Screenshot 2023-04-05 at 1.31.19 PM

These errors also arise when we run roslaunch stretch_core stretch_driver.launch

Some more details on this.
It seems the camera is constantly crashing and resetting.
Below are two images showing the errors that occur when this crash and reset happens.

Hi Zackory,

It certainly seems that there may be a hardware issue (cable or camera). Mohamed (our RealSense expert) will follow up shortly.

FWIW, this guide can help with software related issues.

More soon.

Okay we fixed this (hopefully it continues working).

We tried unplugging the real sense in the head (at the USB C side of the cable and plugging the cable into a brand new D435i and it still kept crashing (so it was either the software or cable, not the realsense).
We plugged the new D435i into the back of the robot via a new USB cable and it worked, so there was an issue with the cable.

Previously the real sense was plugged directly into the Intel NUC.
Ultimately, we unplugged the real sense from the NUC and plugged it into an open port on one of the USB hub splitters inside the robot and now the camera works.


Hi @Zackory, We are glad you were able to fix the issue by yourself. Thank you for providing the error outputs and debug methodology, which is very helpful for us to profile our realsense issues. Please let us know when the problem pops up again.