Stretch2 not detecting USB3.0 Flash Drive


I am currently using a Memorex 128GB usb2.0 flash drive as an external storage space for data. I was hoping to use a SanDisk Ultra 512GB usb3.0 flash drive for improved speeds; however, the robot does not seem to be detecting it.

Debugging Steps Taken:

  • I’ve verified that the usb3.0 flash drive does work by checking on a separate Ubuntu20.04 machine.
  • It seems to be a detection issue instead of a mounting issue since there have been no changes in the output from dmesg, lsusb, or lsblk when I plug the usb3.0 drive in.
  • The same ports I’m plugging the usb3.0 flash drive into work for the usb2.0 flash drive
  • Initially I thought the casing of the USB3.0 flash drive was preventing it from plugging all the way in, so I tried using a usb3.0 extender cable. The cable wobbles a decent amount in the slots; it works consistently for the usb2.0 drive but not the usb3.0 drive. I have been able to get the cable to work for the usb3.0 very inconsistently in the leftmost slot.

Are there any known fixes for this issue? Or are there any other methods I could use to debug this? Any pointers would be appreciated.

Michelle Zhang

Hi Michelle,

Have you tried every single port on your Stretch 2 (ie Shoulder Port, Head Port, Wrist Port)?
Even though the other ports on Stretch are USB2.0 they should be able to detect when a 3.0 device is being plugged in

And if you have other usb3.0 devices like a hub could you try plugging that in and seeing if Stretch is recognizing that

If you have any more questions please feel free to reach out,