Stretch3 not booting up

Hello,

We received our Stretch3 robot earlier this week and have been setting things up. We are troubleshooting some issues with the gripper camera (see this thread – thank you to the Hello Robot team for your support thus far!) but had not had any issues with powering up/booting up the robot until today. However, we tried powering on the robot this morning and were unable to get the computer to boot up. We have been troubleshooting for several hours but have not been able to fix the issue, so we would greatly appreciate your guidance.

Below is a breakdown of our observations and troubleshooting:

  1. Before being powered on this morning, Stretch3 was powered off and charging. The charger indicated a full charge (right-most indicator on scale was green, rest of the scale was unlit).

  2. We disconnected the robot from the charger and connected it to a monitor, mouse and keyboard (same setup we have been using for the past five days).

  3. After pressing the power button to turn the robot on, the LIDAR began turning and the runstop button and microphone lights lit up. The battery indicator bar on the robot’s base also lit up (green color). However, the double beep and Ubuntu start-up sound did not play. On the monitor screen, we observed the following messages: video1 and video2.

These error messages continued showing until we powered off the robot. During certain subsequent tests (see step 4), we did not get xpad error messages and instead just saw a blinking white cursor after the iwlwifi 0000:00:14.3: wrt: invalid buffer destination error.

  1. When we get the blinking cursor screen, we can see a tty login request if we press a function key, but this immediately disappears when we release the key (video).

  2. We turned the robot off and on again via the power switch, repeating this several times throughout the day, but we keep receiving the same messages and not being to reach the Ubuntu desktop page. Note that, during every trial, the LIDAR, runstop, microphone, and green battery indicator all remained on from power on to power off. They weren’t only on momentarily.

  3. We checked the robot battery’s voltage with a DMM using the steps in Docs and followed the process of turning the robot from off to on with the DMM connected based on this forum thread. The voltage was stable at 13.27V while Stretch3 was off. When we powered it on, the voltage started dropping slowly. We left the robot on and checked the voltage again after ~7 min, finding it stable at 12.75V.

  4. Our charger has also not gone into standby mode while connected to the robot, so we don’t think the booting issue is caused by a battery or charger problem.

  5. We followed general Ubuntu debugging steps from the web (opening recovery mode, running clean and other commands from the menu in photo below), but this has not resolved the issue.

  6. An extra note: we noticed an orange light blinking near the LIDAR (video). Does this indicate an issue or is it normal? We’re not sure if it was off before today or if it was on and we simply didn’t notice.

Please let us know how we might be able to fix the booting problem. Thank you!

Hi @zktlks, I’m sorry that you’re facing this issue. One common scenario I’ve seen is where the robot refused to boot up because the hard drive is full. We can check to see if this is the case by booting into recovery mode, selecting “root” and dropping into a root shell, and then running df -h. Would you capture what that command returns for you?

@zktlks Is the gamepad controller’s dongle plugged into the robot’s trunk while you’re booting the robot? If so could you unplug this dongle from the trunk and then start the robot?

Hi @bshah, below is the output that I get. It doesn’t seem like the hard drive is full.

For context, the way I got to this shell was:

  1. Turned on robot wit monitor, keyboard, and mouse already plugged in. I removed the USB dongle before starting this process.
  2. Shift + F2 to get into menu.
  3. Selected “Advanced options for Ubuntu.”
  4. On next page, selected “Ubuntu, with Linux 6.5.0-35-generic (recovery mode).”
  5. In recovery menu, selected “root.”

For the next steps in troubleshooting, I was thinking of either following the steps here using boot repair or following the HelloRobot github docs for erasing a corrupted OS and setting up stretch with an entirely fresh software stack. Would you recommend either of these, or would it be better to try something else first?

Thank you.

Hi @Mohamed_Fazil, I have tried booting the robot both with and without the dongle plugged in. The iwlwifi 0000:00:14.3: wrt: invalid buffer destination error occurs for both; the only difference is that, when the dongle is not plugged in, I do not get the xpad error messages.

The df -h output in my response above is when the dongle is not plugged in.