Troubleshooting operating motor for right wheel and lift

I was initially able to successfully follow the quick start guide on the documentation and was able to successfully run and We recently faced a series of errors resulting in the robot not being able to home correctly. Below, I have listed the series of pertinent events in order:

  1. [1 week ago] We were able to successfully pass all system checks and all tests outputted green.

  2. [Today] We experimented with the grasp_object demo file and observed that we ran into a warning that complained about IMU transforms.

  3. We ran “” followed by “” and some of the PIMU system checks failed and remained red.

  4. We attempted to update the robot’s firmware to the latest version by running “ —install”. We ran into the following error:


  1. We also tried to use —install_version to reset all firmware versions to idx 0 (oldest available version). This resulted in the same error

  2. At this state, fails to move the motor lift.

During Homing lift, the robot does not actually lift the arm all the way to the top and instead senses its current location as the 1m mark. We also observed that we are no longer able to manually move the arm smoothly (it makes a very rough and jerky sound).

We were unable to find any solution to this problem online or on the hello-robot forum and are therefore reaching out to you. Is there a way to completely factory reset the robot?

Hi @skomatin, welcome to the forum! The screenshot indicates a few errors with updating firmware. Recovering the boards and updating their firmware should resolve the main issues you’re experiencing. Please reach out to us via email at, and we’ll recover the robot and address the other issues described here.