Stretch gripper homing failed


On startup, the gripper doesn’t home. The motor of the gripper makes vibrating noise, but gripper doesn’t move.

When I try running, it displays
Moving to hardstop…
[WARNING] [stretch_gripper]: Timed out moving to first hardstop. Exiting.

Meanwhile, the gripper motor makes vibrating sounds until the homing exits.

I tried running and no errors popped up.

I have tried taking out and inserting back the gripper cable.

Could anyone let me know what should I do?

Hi Himani,

If you can hear the motor turning but the fingers don’t move, it’s possible something may have broken within the gripper mechanism. As the gripper is very easy to swap out, I’d recommend we just send you a replacement and get the original one back to debug. Please reach out to us via email at with your address information, and we can get that in motion quickly!


Thank you for the solution. I emailed the support team but haven’t heard back from them yet. Could you please escalate this issue?

The replacement has been shipped - I’ll send you the tracking info via email!