Unable to setup new user on Stretch RE2

Hi guys,

In order to safely add new packages to the Robot, I decided to create a new user following the new user tutorial.

I was unable to install the Stretch packages:

sudo ./stretch_new_user_install.sh
[sudo] password for hello-user: 
Sorry, user hello-user is not allowed to execute './stretch_new_user_install.sh' as root on stretch-re2-2029.


1 Like

Hey @roboor,

I was trying to set up a new user on a robot and I encountered the same issue. To get around this, switch back to the primary user and give Administrator access to the new user.

Then, switch to the new user and execute the command as mentioned in the guide:

cd ~/stretch_install


1 Like

Thanks @chintujaguar!

I tried it again and it works!

After executing colcon build in the catkin_ws and updating everything according to this documentation page, I get the following feedback after running stretch_robot_system_check.py.

~$ stretch_robot_system_check.py 
For use with S T R E T C H (R) RESEARCH EDITION from Hello Robot Inc.

---- Checking Devices ----
[Pass] : hello-wacc
[Pass] : hello-motor-left-wheel
[Pass] : hello-pimu
[Pass] : hello-lrf
[Pass] : hello-dynamixel-head
[Pass] : hello-dynamixel-wrist
[Pass] : hello-motor-arm
[Pass] : hello-motor-right-wheel
[Pass] : hello-motor-lift
[Pass] : hello-respeaker

---- Checking Pimu ----
[Pass] Voltage = 13.988701105117798
[Pass] Current = 1.7963467165827753
[Pass] Temperature = 35.80354329867241
[Pass] Cliff-0 = -10.18255615234375
[Pass] Cliff-1 = 1.5069580078125
[Pass] Cliff-2 = 7.6129150390625
[Pass] Cliff-3 = 7.79583740234375
[Pass] IMU AZ = -9.760787963867188
[Pass] IMU Pitch = -1.9477473497390747
[Pass] IMU Roll = 2.5327301025390625

---- Checking EndOfArm ----
[Pass] Ping of: stretch_gripper
[Pass] Calibrated: stretch_gripper

[Pass] Ping of: wrist_yaw
[Pass] Calibrated: wrist_yaw

---- Checking Head ----
[Pass] Ping of: head_pan

[Pass] Ping of: head_tilt

---- Checking Wacc ----
[Pass] AX = 9.732443809509277

---- Checking hello-motor-left-wheel ----
[Pass] Position = -2.517462968826294

[ERROR] [hello-motor-left-wheel]: SerialException: /dev/hello-motor-left-wheel : write failed: [Errno 9] Bad file descriptor

---- Checking hello-motor-right-wheel ----
[Pass] Position = -2.639286994934082

---- Checking hello-motor-arm ----
[Pass] Position = 14.5787353515625
[Pass] Position Calibrated = True

---- Checking hello-motor-lift ----
[Pass] Position = 62.81527328491211
[Pass] Position Calibrated = True

---- Checking for Intel D435i ----
Bus 004 Device 002: ID 8086:0b3a Intel Corp. Intel(R) RealSense(TM) Depth Camera 435i
[Pass] : Device found 

---- Checking Software ----
[Warn] Ubuntu 20.04 not ready (ros-galactic-librealsense2 not set-up correctly)
[Pass] Firmware is up-to-date
         hello-pimu = v0.5.1p3
         hello-wacc = v0.5.1p3
         hello-motor-arm = v0.5.1p3
         hello-motor-lift = v0.5.1p3
         hello-motor-left-wheel = v0.5.1p3
         hello-motor-right-wheel = v0.5.1p3
[Pass] Python pkgs are up-to-date
         Stretch Body = 0.5.5
         Stretch Body Tools = 0.4.17
         Stretch Tool Share = 0.2.8
         Stretch Factory = 0.4.10
         Stretch Diagnostics = 0.0.14
[Warn] ROS Noetic not ready (stretch_core not set-up correctly)

Is there anything left to do? These warnings don’t look ignorable.

Hello @roboor,

Depending on the layer of our software stack you wish to work on, the most severe of them seems to be the SerialException on hello-motor-left-wheel. Do you see the same error after rebooting the robot?


Hi @chintujaguar,

Yes I get teh same error after rebooting.


Hey @roboor,

I just confirmed with my team that the SerialException message in the system check tool is a false negative. I apologize for the inconvenience. Please try using the stretch_base_jog.py tool to ensure that the left wheel is functional during base teleoperation. You can ignore the warning if it works. Please check this by executing the below script in a terminal and following the prompts:


Let me know how it goes!

Chintan Desai